It's a confusing operand, but it limits versions to a subset of the possible versions. So ~> 2.0.0 means ">= 2.0.0 and < 2.1.0" in version numbers.

1.2.3 seems to be the latest version of Formtasic, that's why you're getting this error message.