This worked for me when downgrading from 1.5.2 to 1.4.2 because of old rails version:

sudo gem update --system 1.4.2

More information about downgrading/upgrading rubygems: https://github.com/rubygems/rubygems/blob/master/UPGRADING.md